Logo GenDocs.ru

Поиск по сайту:  


Загрузка...

Контрольная работа - Учет товаров и расчеты с контрагентами - файл Отчет.docx


Контрольная работа - Учет товаров и расчеты с контрагентами
скачать (276.6 kb.)

Доступные файлы (4):

Отчет.docx141kb.01.03.2011 21:24скачать
1Cv8.1CD
1Cv8.log
1Cv8.pfl

содержание
Загрузка...

Отчет.docx

Реклама MarketGid:
Загрузка...
КОНТРОЛЬНАЯ РАБОТА

по дисциплине «Предметно-ориентированные экономические информационные системы»

Проверил:

Батищев Павел Сергеевич

Дата: «___»____________2010 года

Подпись:______________________

город Киров – 2010 год




1. Теоретическая часть
Цель работы – разработка и проектирование конфигурации, не зависящей ни от одной базовой конфигурации в среде 1С 8.0.

Постановка задачи – разработать собственную конфигурацию для автоматизации задачи учета товаров и расчетов с контрагентами.

Предметная область – оптово-розничная фирма, суть деятельности которой заключается в покупке материалов и перепродажи их оптово-розничными партиями.

Программа должна содержать:

1) справочники:

- номенклатура – сведения о товаре;

- контрагенты – сведения о поставщиках и покупателях;

- сотрудники – сведения о работниках (менеджеры и продавцы);

- места хранения – сведения о складах;

2) документы:

– заказ поставщику;

- поступление товаров (подчинен «заказ поставщику»);

- перемещение товара;

- отпуск товара;

- расчеты;

3) отчеты:

- остатки материалов;

- оборотно-сальдовая ведомость;

- ведомость по счету;

- продажи сотрудников;

- акт сверки;

4) план видов характеристик – план субконто;

5) план счетов – Главный;

6) регистр сведений – последняя цена;

7) регистры накопления – товары, поставщики, покупатели;

8) регистр бухгалтерии – журнал проводок.

^ 2. Практическая часть

В конфигураторе 1С 8.0 создаем новую пустую информационную базу «Учебная». Далее создаем роль «Учебная», имеющую все права. Затем создаем интерфейс «Учебный» со всеми объектами и добавляем пользователя (без пароля).

После этого приступаем к созданию требуемых объектов конфигурации:

1. Справочники со следующими параметрами (табл. 1):

Таблица 1

Объект

Свойства

Дополнительно

Справочник Номенклатура

Имя: Номенклатура




Иерархия: групп и элементов

Справочник Контрагенты

Имя: Контрагенты




Иерархия: групп и элементов

Справочник Сотрудники

Имя: Сотрудники




Иерархия: групп и элементов

Реквизиты: ФИО_кратко

Тип: строка (25)

Табличная часть: Информация




Реквизиты табличной части: Адрес, Дата_приема

Тип: строка (100), дата

Справочник Места хранения

Имя: Места_хранения




Иерархия: групп и элементов


2. Документы со следующими параметрами (табл. 2):

Таблица 2

Объект

Свойства

Дополнительно

Документ Заказ поставщику

Имя: Заказ_поставщику

Является основанием для: Документ.Поступление_товаров

Реквизиты: поставщик, получатель

Тип: СправочникСсылка.Контрагенты,

СправочникСсылка.Места_хранения

Реквизиты табличной части:

Наименование, Количество

Тип: СправочникСсылка.Номенклатура, Число (14)

Справочник Поступление товаров

Имя: Поступление_товаров

Вводится на основании: Документ.Заказ_поставщику

Реквизиты: Поставщик, Получатель

Тип: СправочникСсылка.Контрагенты, СправочникаСсылка.Места_хранения

Реквизиты табличной части: Наименование, Количество, Цена, Сумма

Тип: СправочникСсылка.Номенклатура, Число (14), Число (14), Число (14)

Движения: регистр сведений (последняя

_ цена), регистр накоплений (товары, поставщик), регистр бухгалтерии (журнал_проводок)

Справочник Отпуск товара

Имя: Отпуск_товара

Реквизиты: получатель, места_хранения, продавец

Тип: СправочникСсылка.Контрагенты, СправочникСсылка.Места_хранения, СправочникСсылка.Сотрудники

Реквизиты табличной части: Наименование, Количество, Цена, Сумма

Тип: СправочникСсылка.Номенклатура, Число (14), Число (14), Число (14)

Движения: регистры накопления (товары, покупатели), регистры бухгалтерии (журнал_проводок)

Документ Перемещение товаров

Имя: Перемещение_товаров

Движение: регистры накоплений (товары), регистры бухгалтерии (журнал_проводок)

Реквизиты: поставщик, получатель

Тип: СправочникСсылка.Контрагенты, СправочникСсылка.Места_хранения

Реквизиты табличной части: наименование, количество, цена, сумма

Тип: СправочникСсылка.Номенклатура, число (14), число (14), сумма (14)

Документ Расчеты

Имя: Расчеты

Реквизиты табличной части Банк: Контрагент, Приход, Расход

Тип: СправочникСсылка.Контрагенты, Число (14), Число (14)

Реквизиты табличной части Касса: Контрагент, Приход, Расход

Тип: СправочникСсылка.Контрагенты, Число (14), Число (14)
В документе «Поступление_товаров» проводим настройку при помощи Конструктора ввода на основании. В документе «Перемещение_товаров» создаем макет печатной формы при помощи Конструктора печати. В модуль формы документов «Поступление_товаров», «Отпуск_товаров», «Перемещение_товаров» вводим для расчета суммы следующие процедуры:

Процедура ТоварыКоличествоПриИзменении(Элемент)

Итого();

КонецПроцедуры
Процедура ТоварыЦенаПриИзменении(Элемент)

Итого();

КонецПроцедуры
Процедура Итого()

стр = ЭлементыФормы.Товары.ТекущаяСтрока;

стр.Сумма = стр.Количество * стр.Цена;

КонецПроцедуры
Дополнительно в модуль формы документа «Поступление_товаров»:

Процедура ТоварыНаименованиеПриИзменении(Элемент)

стр = ЭлементыФормы.Товары.ТекущаяСтрока;

отбор = Новый Структура("Наименование", стр.Наименование);

стр.Цена = РегистрыСведений.Последняя_цена.ПолучитьПоследнее(Дата, отбор).Цена;

Итого();

КонецПроцедуры
В модуль формы документов «Расчеты_с_поставщиками» и «Расчеты_с_покупателями» вводим для расчета суммы долга следующие процедуры:

Процедура Долг()

стр = ЭлементыФормы.Таблица.ТекущаяСтрока;

стр.Долг = стр.Сумма-стр.Проплата

КонецПроцедуры
Процедура ТаблицаПроплатаПриИзменении(Элемент)

Долг();

КонецПроцедуры
В модуль документа «Поступление_товаров» вводим некоторые дополнения в программный код и получаем:

Процедура ОбработкаПроведения(Отказ, Режим)

//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

// Данный фрагмент построен конструктором.

Для Каждого ТекСтрокаТовары Из Товары Цикл

// регистр Товары Приход

Движение = Движения.Товары.Добавить();

Движение.ВидДвижения = ВидДвиженияНакопления.Приход;

Движение.Период = Дата;

Движение.Наименование = ТекСтрокаТовары.Наименование;

Движение.Получатель = Получатель;

Движение.Количество = ТекСтрокаТовары.Количество;

КонецЦикла;

Для Каждого ТекСтрокаТовары Из Товары Цикл

// регистр Последняя_цена

отбор = Новый Структура("Наименование",ТекСтрокаТовары.Наименование);

максЦена = РегистрыСведений.Последняя_цена.ПолучитьПоследнее(ТекущаяДата(),отбор).Цена;

если максЦена < ТекСтрокаТовары.Цена тогда

Движение = Движения.Последняя_цена.Добавить();

Движение.Период = ТекущаяДата();

Движение.Наименование = ТекСтрокаТовары.Наименование;

Движение.Цена = ТекСтрокаТовары.Цена;

конецЕсли;

КонецЦикла;

Для Каждого ТекСтрокаТовары Из Товары Цикл

// регистр Поставщики

Движение = Движения.Поставщики.Добавить();

Движение.Период = Дата;

Движение.Поставщик = Поставщик;

Движение.Наименование = ТекСтрокаТовары.Наименование;

Движение.Количество = ТекСтрокаТовары.Количество;

КонецЦикла;

Для Каждого ТекСтрокаТовары Из Товары Цикл

// регистр ЖурналПроводок

Движение = Движения.Журнал_проводок.Добавить();

Движение.СчетДт = ПланыСчетов.Главный.Сырье_и_материалы;

Движение.СубконтоДт[ПланыВидовХарактеристик.ПланСубконто.Номенклатура] = ТекСтрокаТовары.Наименование;

Движение.СубконтоДт[ПланыВидовХарактеристик.ПланСубконто.Места_хранения] = Получатель;

Движение.СубконтоДт[ПланыВидовХарактеристик.ПланСубконто.Контрагенты] = Поставщик;

Движение.СчетКт = ПланыСчетов.Главный.Расчеты_с_поставщиками_и_подрядчиками;

Движение.СубконтоКт[ПланыВидовХарактеристик.ПланСубконто.Контрагенты] = Поставщик;

Движение.Период = Дата;

Движение.Сумма = ТекСтрокаТовары.Сумма;

Движение.КоличествоДт = ТекСтрокаТовары.Количество;

КонецЦикла;

// записываем движения регистров

Движения.Товары.Записать();

Движения.Последняя_цена.Записать();

Движения.Поставщики.Записать();

Движения.Журнал_проводок.Записать();

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ

КонецПроцедуры
Процедура ОбработкаЗаполнения(Основание)

//{{__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

// Данный фрагмент построен конструктором.

Если ТипЗнч(Основание) = Тип("ДокументСсылка.Заказ_поставщику") Тогда

// Заполнение шапки

Получатель = Основание.Получатель;

Поставщик = Основание.Поставщик;

Для Каждого ТекСтрокаТаблица Из Основание.Таблица Цикл

НоваяСтрока = Товары.Добавить();

НоваяСтрока.Количество = ТекСтрокаТаблица.Количество;

НоваяСтрока.Наименование = ТекСтрокаТаблица.Наименование;

НоваяСтрока.Цена=Взять_цену(Дата, НоваяСтрока.Наименование);

НоваяСтрока.Сумма=НоваяСтрока.Количество*НоваяСтрока.Цена;

КонецЦикла;

КонецЕсли;

//}}__КОНСТРУКТОР_ВВОД_НА_ОСНОВАНИИ

КонецПроцедуры
Аналогичный код вводим в модуль документов «Перемещение_товара», «Отпуск_товара».
3. Регистры со следующими параметрами (табл. 3):

Таблица 3

Объект

Свойства

Дополнительно

Регистр сведений Последняя цена

Имя: Последняя_цена




Измерения: Наименование

Тип: СправочникСсылка.Номенклатура

Ресурсы: Цена

Тип: Число (14)

Регистраторы: Поступление_товаров




Регистр бухгалтерии Журнал проводок

Имя: Журнал_проводок




Ресурсы: Сумма, Количество

Тип: Число (14), Число (14)

Регистраторы: Поступление_товаров, Перемещение_товара, Отпуск_товара




Регистр накопления Товары

Имя: Товары

Вид регистра: Обороты

Измерения: наименование, получатель

Тип: СправочникСсылка.Номенклатура, СправочникСсылка.Места_хранения

Ресурсы: количество

Тип: число (14)

Регистр накоплений Поставщики

Имя: Поставщики

Вид регистра: Обороты

Измерения: Поставщик, Наименование

Тип: СправочникСсылка.Контрагенты, СправочникСсылка.Номенклатура

Ресурсы: количество

Тип: Число (14)




Регистраторы: Поступление_товаров

Регистр накоплений Покупатели

Имя: Покупатели

Вид регистра: Остатки

Измерения: Покупатель, Наименование, Продавец

Тип: СправочникСсылка.Контрагент, СправочникСсылка.Номенклатура, СправочникСсылка.Сотрудник

Ресурсы: Количество

Тип: Число (14)




Регистраторы: Отпуск_товара


4. План видов характеристик

Имя: ПланСубконто

Тип значения характеристик: СправочникСсылка.Номенклатура

Предопределенные виды характеристик (табл. 4)

Таблица 4

Характеристика

Код

Наименование

Тип

Номенклатура

00001

Номенклатура

СправочникСсылка.Номенклатура

Сотрудники

00002

Сотрудники

СправочникСсылка.Сотрудники

Контрагенты

00003

Контрагенты

СправочникСсылка.Контрагенты

Места_хранения

00004

Места хранения

СправочникСсылка.Места_хранения


5. План счетов

Имя: Главный

Реквизиты: Признаки учета – Количественный

Признаки учета субконто: Количественный

Предопределенные счета (табл. 5)

Таблица 5

Имя

Код

Наименование

Вид

Количественный

Субконто1

Субконто2

Субконто3

Материалы

10

То же

Активный

+

Номен-клатура

Места_

хранения

Контр-агенты

Сырье и материалы

10.1

То же

Активный

+

Номен-клатура

Места_

хранения

Контр-агенты

Основное_

производство_

20

То же

Активный

+

Номен-клатура

Места_

хранения




Основное_

производство

20.1

То же

Активный

+

Номен-клатура

Места_

хранения




Расчеты_с_

поставщиками_и_

подрядкиками_

60

То же

Активно-пассивный

-

Контр-агенты







Расчеты_с_

поставщиками_и_

подрядчиками

60.1

То же

Пассивный

-

Контр-агенты







Расчеты_с_

покупателями_и_заказчиками

62

То же

Активно-пассивный

-

Контр-агенты







Расчеты_с_покупателями

62.1

То же

Активный

-

Контр-агенты







Касса

50

То же

Активный

+










Расчетный_

счет

51

То же

Активный

+











6. Все отчеты создаются при помощи Конструктора.

В отчете «Оборотно-сальдовая ведомость» в параметры виртуальной таблицы вводятся начало периода - &ДатаН, конец периода - &ДатаК для возможности установления пользователями.

В отчете «Ведомость по счету» в параметры виртуальной таблицы вводятся начало периода - &ДатаН, конец периода - &ДатаК, условие счета – Счет = &ВыбСчета для возможности установления пользователями.

Аналогично и в остальных отчетах вводятся требуемые параметры для удовлетворения условий выполнения отчета.

3. Результаты

После проделанной работы имеем конфигурацию, разработанную в качестве учебного примера и имеющую все основные объекты. В режиме 1С пользователь может работать с формами документов, справочниками, регистрами и отчетами (пример внешнего вида некоторых объектов приведен на рисунках ниже).


Рис. 1 Справочник Номенклатура


Рис. 2 Документы Поступление товаров


Рис. 3 Форма ввода документа Поступление товаров


Рис. 4 Результат выполнения отчета Акт сверки с поставщиками

Рис. 5 Результат выполнения отчета Акт сверки с покупателями

Рис. 6 Регистр бухгалтерии Журнал проводок

Рис. 7 Регистр сведений Последняя цена

Рис. 8 Регистр накопления Товары

Полезные ссылки:

http://my1s.ru/?page_id=32

http://www.firststeps.ru/1c/mp2/Index.htm#acont

http://www.sbp-program.ru/SBP_1c_8_0.htm


Скачать файл (276.6 kb.)

Поиск по сайту:  

© gendocs.ru
При копировании укажите ссылку.
обратиться к администрации
Рейтинг@Mail.ru