Logo GenDocs.ru

Поиск по сайту:  


Загрузка...

Cisco Dynamips - файл telecom.doc


Cisco Dynamips
скачать (1564.8 kb.)

Доступные файлы (18):

cg-report.sty
09_1_1.png59kb.17.06.2010 19:48скачать
09_2.png33kb.17.06.2010 21:34скачать
10_1_1.png46kb.17.06.2010 19:49скачать
10_2.png41kb.17.06.2010 21:34скачать
b_1_1.png57kb.17.06.2010 19:47скачать
bravo2.png47kb.17.06.2010 21:34скачать
ping1_1.png45kb.17.06.2010 19:36скачать
ping2_1.png20kb.17.06.2010 21:33скачать
Thumbs.db
sample.aux
sample.log
sample.pdf457kb.17.06.2010 21:50скачать
sample.tex
telecom.doc145kb.27.05.2010 03:26скачать
tilibom.pdf421kb.27.05.2010 07:31скачать
sample.doc112kb.20.06.2010 18:03скачать
my.doc510kb.21.06.2010 04:54скачать

содержание
Загрузка...

telecom.doc

Реклама MarketGid:
Загрузка...


М О С К О В С К И Й А В И А Ц И О Н Н Ы Й И Н С Т И Т У Т


Факультет прикладной математики и физики.


Кафедра вычислительной математики и программирования


Отчет по лабораторным работам по курсу «Телекоммуникации»


Выполнил: Долгов Д.А. студент группы 08-406.

Проверил: Филимонов Н.С.


Оценка:

Дата:


Москва

2010



  • Введение.

Данный курс посвящен настройкам созданию и настройки сетей. Лабораторные работы проводятся на основе интерактивного эмулятора модульных платформ Cisco Systems 7206VXR (с сетевыми процессорами NPE-400 и NPE-300) и 3640. В платформах 7206VXR используются модули С7200-IO-FE, PA-FE-TX, PA-8E; в платформах 3640 используются модули NM-1E, NM-1FE-TX. В ходе выполнения этих лабораторных работ рассматриваются два подхода для маршрутизации сетей, один основан на статической маршрутизации, а другой на основе протокола маршрутизации OSPF.



  • ^ Лабораторная работа №1: «Конфигурирование статической маршрутизации».

Основная задача данной лабораторной работы заключается в ознакомлении с построением и настройкой сетей. В ходе данной лабораторной работы потребуется не только настраивать сеть, но также администрировать роутеры. На основе простой сети требуется опробывать статическую маршрутизацию и в случае неполадок с подключением суметь диагностировать их.


    • ^ Постановка задачи.

Требуется создать простую сеть из нескольких маршрутизаторов, состоящую из двух клиентских роутера и одиного роутера принадлежащего оператору. До начала настройки подключений на каждом маршрутизаторе должны быть выполнены следующие задачи:


  • Задано имя маршрутизатора в соответствии со схемой. Для клиентских маршрутизаторов именем является ClientXX где XX номер варианта (01, 02 и тп).

  • Созданы пользователи student и supervisor с уровнем привилегий 15 и паролями, равными имени пользователя

  • По окончании работы конфигурация маршрутизатора должна быть сохранена с использованием команды copy running-config startup-config.

После того, как необхобходимые служебные настройки роутера были выполнены, требуется настроить и протестировать три IP-интерфейса, а также в случае возникновения неполадок скооперироваться для поиска и устранения проблем с подключением.


    • ^ Аппаратное и программное обеспечения.

Данная лабораторная работа выполнялась на ноутбуке Asus F3Sseries, версии F3SV.

Основные характеристики данной машины приводятся в таблице №1 ниже.



Устройство

Модель и основные характеристики

Процессор

Intel Centrino Core 2 Duo, T7500, два ядра по 2.2 Ггц

Видеокарта

GeForce 8600M GS, 256 MB

ОЗУ

2 GB


Для реализации сети использовалась виртуальная машина бесплатно распространяемая компанией Microsoft, сама же сеть эмулировалась с помощью программы Dynamips, с импользованием надстройки над ним в виде Dynagen. В качестве операционной системы использовалась Windows XP Service Pack 2.


    • ^ Ход выполнения поставленной задачи.

Для выполнения данной лабораторной работы было скачано все необходимое

программное обеспечение, а также дополнительные программы в виде вуртуальной машины VirtualPC и других полезных компанент. После установки и настройки всего программного обеспечения, была смоделирована сеть из трех маршритизаторов, два из которых представляют собой клиентские роутеры и одного роутера оператора. Клиентские роутеры представляют собой эмулятор модульных платформ Cisco Systems 3640, роутер оператора представляет собой эмулятор модульной платформы Cisco Systems 7206VXR. Общий вид моделируемой сети можно увидеть на Рис. №1 в разделе “Результаты”. После того, как сеть была создана, а также были выполнены все общие требования по настройке роутеров начинается этап маршрутизации данной сети.

Основной функцией маршрутизаторов является маршрутизация информации из одной сети в другую. В маршрутизаторах есть таблица маршрутизации, соответственно которой маршрутизируются  данные устройством. Во время статической маршрутизации администратор вручную прописывает пути из одной сети в другую, это не очень сложный процесс

После того, как настройка статической маршрутизации была выполнена, работоспособность сети была проверена с помощью команды ping. Результаты пинга,а также конфигурационные файлы можно увидеть в разделе “Результаты”.


    • Результаты.

Ниже приводятся скриншоты общей топологии сети и результатов команды ping, а

также конфигурационные файлы каждого из роутеров.


(РИСУНКИ)


Конфигурационный файл общей топологии сети:

[localhost]


[[7200]]

image = \Program Files\Dynamips\images\c7200-is-mz.122-40.bin

ram = 128

npe = npe-300


[[3640]]

image = \Program Files\Dynamips\images\c3640-is-mz.122-40.bin

ram = 64

model = 3640

slot0 = NM-1E

slot1 = NM-1FE-TX

slot2 = NM-1FE-TX



[[ROUTER Bravo]]

model = 7200

slot0 = C7200-IO-FE

slot1 = PA-8E

f0/0 = LAN 1

e1/0 = Client09 e0/0

e1/1 = Client10 e0/0

console = 2000


[[ROUTER Client09]]

model = 3640

f1/0 = LAN 2

f2/0 = LAN 29

console = 2010



[[ROUTER Client10]]

model = 3640

f1/0 = LAN 2

f2/0 = LAN 30

console = 2011


Конфигурационный файл роутера “Bravo”:

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Bravo

!

aaa new-model

aaa authentication login default local

!

username student privilege 15 password 0 student

username supervisor privilege 15 password 0 supervisor

ip subnet-zero

ip cef

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.100.3 255.255.255.0

duplex half

!

interface Ethernet1/0

ip address 192.168.50.33 255.255.255.252

duplex half

!

interface Ethernet1/1

ip address 192.168.50.37 255.255.255.252

duplex half

!

interface Ethernet1/2

ip address 192.168.50.41 255.255.255.252

duplex half

!

interface Ethernet1/3

ip address 192.168.50.45 255.255.255.252

duplex half

!

interface Ethernet1/4

ip address 192.168.50.49 255.255.255.252

duplex half

!

interface Ethernet1/5

ip address 192.168.50.53 255.255.255.252

duplex half

!

interface Ethernet1/6

ip address 192.168.50.57 255.255.255.252

duplex half

!

interface Ethernet1/7

ip address 192.168.50.61 255.255.255.252

duplex half

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 192.168.9.0 255.255.255.0 Ethernet1/0

ip route 192.168.10.0 255.255.255.0 Ethernet1/1

no ip http server

!

!

dial-peer cor custom

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

line aux 0

line vty 0 4

transport input telnet

!

end


Конфигурационный файл роутера “Client09”:

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Client09

!

aaa new-model

aaa authentication login default local

!

username student privilege 15 password 0 student

username supervisor privilege 15 password 0 supervisor

ip subnet-zero

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface Ethernet0/0

ip address 192.168.50.34 255.255.255.252

half-duplex

!

interface FastEthernet1/0

ip address 192.168.60.25 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 192.168.9.1 255.255.255.0

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0/0

ip route 192.168.10.0 255.255.255.0 Ethernet0/0

ip http server

!

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

transport input telnet

!

end


Конфигурационный файл роутера Client10”:

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Client10

!

aaa new-model

aaa authentication login default local

!

username student privilege 15 password 0 student

username supervisor privilege 15 password 0 supervisor

ip subnet-zero

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

interface Ethernet0/0

ip address 192.168.50.38 255.255.255.252

half-duplex

!

interface FastEthernet1/0

ip address 192.168.60.26 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 192.168.10.1 255.255.255.0

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0/0

ip route 192.168.9.0 255.255.255.0 Ethernet0/0

ip http server

!

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

transport input telnet

!

end


    • Выводы

Как упоминалось выше статическая маршрутизация является достаточно простым

способом маршрутизации. Как уже говорилось выше, данный вид маршрутизации удобно применять для малых и несложных сетей. На примере данной лабораторной работы можно лучше понять сам принцип маршрутизации. То есть проходя по сети мысленно, лучше осмысливается сам процесс маршрутизации между роутерами, другими словами приходит понимания, как они общаются между собой.

Помимо программы Dynamips, существует другие программы аналог, например Packet

Tracer, которая имеет также графическую надстройку. Стоит отметить, что помимо текстовой надстройки для Dynamips в виде программы Dynagen, топология сети в этом случае задается в текстовом файле, поэтому можно считать, что данная надстройка текстовая, существует также графическая надстройка в виде программы GNS3. В данной программе например была построена общая топология сети для визуализации. Тем не менее, сама лабораторная работа выполнялась с помощью программы Dynagen.



  • ^ Лабораторная работа №2: «Протокол динамической маршрутизации OSPF».

Цель данной лабораторной работы ознакомление с принципа настройки и работы с протоколом динамической маршрутизации OSPF. На основе просто сети, необходимо опробывать возможности протокола OSPF.


    • ^ Постановка задачи.

В описании данной лабораторной работы предполагается, что используемые маршрутизаторы ранее корректно сконфигурированы в рамках первой лабораторной работы. До начала настройки протоколов маршрутизации на каждом маршрутизаторе должны быть выполнены следующие задачи:

  • Удалены все статические маршруты, за исключением маршрутов по умолчанию.

  • По окончании работы конфигурация маршрутизатора должна быть сохранена с использованием команды copy running-config startup-config.

После того, как необхобходимые служебные настройки роутера были выполнены, требуется настроить и протестировать динамический протокол маршрутизации OSPF, а также в случае возникновения неполадок скооперироваться для поиска и устранения проблем с подключением.


    • ^ Аппаратное и программное обеспечения.

Данная лабораторная работа выполнялась на ноутбуке Asus F3Sseries, версии F3SV.

Основные характеристики данной машины приводятся в таблице №1 ниже.



Устройство

Модель и основные характеристики

Процессор

Intel Centrino Core 2 Duo, T7500, два ядра по 2.2 Ггц

Видеокарта

GeForce 8600M GS, 256 MB

ОЗУ

2 GB


Для реализации сети использовалась виртуальная машина бесплатно распространяемая компанией Microsoft, сама же сеть эмулировалась с помощью программы Dynamips, с импользованием надстройки над ним в виде Dynagen. В качестве операционной системы использовалась Windows XP Service Pack 2.


    • ^ Ход выполнения поставленной задачи.

В данной лабораторной работе не понадобилось никакого нового программного обеспечения, кроме того, что было использовано в первой лабораторной работе. Так как данная лабораторная работа основывается на результатах первой, то прежде чем приступить к главной сути данной лабораторной работы, согласно заданию, были удалены все результаты предыдущей лабораторной работы.

Открытый протокол, базирующийся на алгоритме поиска наикратчайшего пути (Open Shortest Path Fisrt - OSPF) является протоколом маршрутизации, разработанным для сетей IP рабочей группой Internet Engineering Task Force (IETF), занимающейся разработкой протоколов для внутрисистемных роутеров. ОSPF явился результатом научных исследований по нескольким направлениям, включающим:

  • Алгоритм SPF компании Bolt, Beranek и Newman (BBN), разработанный для Arpanet (программы с коммутацией пакетов, разработанной BBN в начале 1970 гг., которая явилась поворотным пунктом в истории разработки сетей) в 1978 г.

  • Исследования Koмпании Radia Perlman по отказоустойчивости широкой рассылки маршрутной информации (1988).

  • Исследования BBN по маршрутизации в отдельной области (1986).

  • Одна из первых версий протокола маршрутизации IS-IS OSI

Одной из главных характеристик OSPF является то, что он базируется на алгоритме SPF. Алгоритм SPF иногда называют алгоритмом Дейкстра.OSPF является протоколом маршрутизации с объявлением состояния о канале (link-state). Это значит, что он требует отправки объявлений о состоянии канала (link-state advertisement - LSA) во все роутеры, которые находятся в пределах одной и тойже иерархической области. В oбъявления LSA протокола OSPF включается информация о подключенных интерфейсах, об использованных показателях и о других переменных. По мере накопления роутерами OSPF информации о состоянии канала, они используют алгоритм SPF для расчета наикратчайшего пути к каждому узлу.

Являясь алгоритмом с объявлением состояния канала, OSPF отличается от RIP и IGRP, которые являются протоколами маршрутизации с вектором расстояния. Роутеры, использующие алгоритм вектора расстояния, отправляют всю или часть своей таблицы маршрутизации в сообщения о корректировке маршрутизации, но только своим соседям.

Сам процесс создания динамической маршрутизации на основе протокола OSPF не

является сложным и трудоемким, учитывая тем более, что рассматриваемая сеть является не очень большой, а также имеется опыт работы с сетями на основе первой лабораторной работы. После того, как маршрутизация была настроена, работоспособность сети была проверена с помощью команды ping.Результаты пинга,а также конфигурационные файлы можно увидеть в разделе “Результаты”.


    • Результаты.

Ниже приводятся скриншоты общей топологии сети и результатов команды ping, а

также конфигурационные файлы каждого из роутеров.


(РИСУНКИ)


Конфигурационный файл общей топологии сети:

[localhost]


[[7200]]

image = \Program Files\Dynamips\images\c7200-is-mz.122-40.bin

ram = 128

npe = npe-300


[[3640]]

image = \Program Files\Dynamips\images\c3640-is-mz.122-40.bin

ram = 64

model = 3640

slot0 = NM-1E

slot1 = NM-1FE-TX

slot2 = NM-1FE-TX



[[ROUTER Bravo]]

model = 7200

slot0 = C7200-IO-FE

slot1 = PA-8E

f0/0 = LAN 1

e1/0 = Client09 e0/0

e1/1 = Client10 e0/0

console = 2000


[[ROUTER Client09]]

model = 3640

f1/0 = LAN 2

f2/0 = LAN 29

console = 2010



[[ROUTER Client10]]

model = 3640

f1/0 = LAN 2

f2/0 = LAN 30

console = 2011


Конфигурационный файл роутера “Bravo”:

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Bravo

!

aaa new-model

aaa authentication login default local

!

username student privilege 15 password 0 student

username supervisor privilege 15 password 0 supervisor

ip subnet-zero

ip cef

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.100.3 255.255.255.0

duplex half

!

interface Ethernet1/0

ip address 192.168.50.33 255.255.255.252

duplex half

!

interface Ethernet1/1

ip address 192.168.50.37 255.255.255.252

duplex half

!

interface Ethernet1/2

ip address 192.168.50.41 255.255.255.252

duplex half

!

interface Ethernet1/3

ip address 192.168.50.45 255.255.255.252

duplex half

!

interface Ethernet1/4

ip address 192.168.50.49 255.255.255.252

duplex half

!

interface Ethernet1/5

ip address 192.168.50.53 255.255.255.252

duplex half

!

interface Ethernet1/6

ip address 192.168.50.57 255.255.255.252

duplex half

!

interface Ethernet1/7

ip address 192.168.50.61 255.255.255.252

duplex half

!

router ospf 100

log-adjacency-changes

network 192.168.50.32 0.0.0.3 area 1

network 192.168.50.36 0.0.0.3 area 1

network 192.168.50.40 0.0.0.3 area 1

network 192.168.50.44 0.0.0.3 area 1

network 192.168.50.48 0.0.0.3 area 1

network 192.168.50.52 0.0.0.3 area 1

network 192.168.50.56 0.0.0.3 area 1

network 192.168.50.60 0.0.0.3 area 1

network 192.168.100.0 0.0.0.255 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

no ip http server

!

!

dial-peer cor custom

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

line aux 0

line vty 0 4

transport input telnet

!

end


Конфигурационный файл роутера “Client09”:

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Client09

!

aaa new-model

aaa authentication login default local

!

username student privilege 15 password 0 student

username supervisor privilege 15 password 0 supervisor

ip subnet-zero

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface Ethernet0/0

ip address 192.168.50.34 255.255.255.252

half-duplex

!

interface FastEthernet1/0

ip address 192.168.60.25 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 192.168.9.1 255.255.255.0

duplex auto

speed auto

!

router ospf 100

log-adjacency-changes

network 192.168.9.0 0.0.0.255 area 1

network 192.168.50.32 0.0.0.3 area 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0/0

ip http server

!

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

transport input telnet

!

end


Конфигурационный файл роутера “Client10”:

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Client10

!

aaa new-model

aaa authentication login default local

!

username student privilege 15 password 0 student

username supervisor privilege 15 password 0 supervisor

ip subnet-zero

!

!

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface Ethernet0/0

ip address 192.168.50.38 255.255.255.252

half-duplex

!

interface FastEthernet1/0

ip address 192.168.60.26 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 192.168.10.1 255.255.255.0

duplex auto

speed auto

!

router ospf 100

log-adjacency-changes

network 192.168.10.0 0.0.0.255 area 1

network 192.168.50.36 0.0.0.3 area 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 Ethernet0/0

ip http server

!

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

transport input telnet

!

end


    • Вывод.

Использование динамических протоколов маршрутизации, в частности протокола OSPF, является более лучшим способом маршрутизации, чем статическая маршрутизация. К сожалению данная лабораторная работа выполнялась на примере малой сети, поэтому тяжело оценить все возможности протокола OSPF, но даже на таком простом примере видно, что данный вид маршрутизации является удобным и не очень сложным в использовании.

Стоит отметить, что существуют другие протоколы динамической маршрутизации, некоторые из них были уже упомянуты выше, так например отмечались такие протоколы как RIP и IGRP, каждый протокол имеет свою особенность, поэтому применение того или иного протокола может быть более выгодно в конкретной ситуации.


Скачать файл (1564.8 kb.)

Поиск по сайту:  

© gendocs.ru
При копировании укажите ссылку.
обратиться к администрации
Рейтинг@Mail.ru