Logo GenDocs.ru

Поиск по сайту:  


Загрузка...

Отчет по практике - файл 1.doc


Отчет по практике
скачать (2634.5 kb.)

Доступные файлы (1):

1.doc2635kb.18.11.2011 15:25скачать

содержание
Загрузка...

1.doc

Реклама MarketGid:
Загрузка...



Министерство образования Российской Федерации

Южно-Уральский государственный университет

Кафедра «Экономика управление и инвестиции»


ОТЧЁТ

по учебной вычислительной практике:
разработка программы расчёта неритмичных
потоков



Руководитель

Маленьких Ю.А.

«____»____________2009


Автор отчёта

студент группы ЗФ– 202

Львова Ю.О.

«___»________________2009


Челябинск

2006


ОГЛАВЛЕНИЕ

Постановка задачи 2

Алгоритм решения 3

Расчет неритмичных потоков табличным и графическим методами. 3

Программа расчёта неритмичного
потока 9

Построение графика (циклограммы) потока 11



^




Постановка задачи


Составить программу расчёта неритмичных потоков табличным методом в среде Microsoft Excel.

Разработать, титульную страницу, кнопочную форму меню, окно ввода данных, расчётную таблицу, циклограмму потока, указания пользователю. Предусмотреть вывод всех результатов на печать.
^ Исходные данные:

переменные: дата начала работы потока и ритмы работы бригад;
постоянные: количество захваток (участков) равно 6 и количество бригад (процессов) равно 7.

^

Алгоритм решения

Расчет неритмичных потоков табличным и графическим методами.



Поточным называется метод организации работ, при котором разнотипные работы на отдельно взятой захватке выполняются в технологической последовательности, а на объекте в целом ( на разных захватках ) - параллельно.

Классификация потоков.

Потоки классифицируются по нескольким признакам:


1. По виду выпускаемой продукции:

  1. частный поток, продукция которого – отдельные виды работ. Это элементарный строительный поток, выполняющий один или несколько однородных процессов одним строительным подразделением;

  2. специализированный поток - продукция комплексы однородных работ (однотипные работы) или части зданий и сооружений (нулевой цикл, коробка, отделка). Специализированный поток состоит из ряда частных потоков объединенный общей целью и единой системой параметров;

  3. объектный поток – продукция готовые объекты (здания, сооружения). Он представляет собой совокупность специализированных и частных потоков, состав которых обеспечивает выполнение всего комплекса работ по строительству объекта. Т.е. они (спецпотоки) объединены общей системой параметров;

  4. комплексный поток – продукция комплексы зданий и сооружений. Он состоит из объектных, спец. и частных потоков, объединенных общей целью и системой параметров.


2. По развитию в пространстве:

  1. объёмные, когда потоки (спец. и частные) развиваются в трех направлениях горизонтальных и вертикальном (возведение многоэтажных промышленных зданий);

  2. линейные - строительство линейных сооружений;

  3. площадные - (плоскостные) одноэтажные здания общеплощадочной работы.


3. По продолжительности работы потока:

1. долговременные (годы);

2. кратковременные (дни, месяцы).


  1. По изменению ритмов работы (ритмов работы бригад):

Ритм работы бригады (Тбр)- время необходимое для выполнения всего объема работы на захватке.

1. ритмичные потоки (равноритмичные) Tбр = const ;

2. неритмичные потоки, в которых частные потоки на имеют постоянного ритма вследствие неоднородности зданий и сооружений. Tбр ≠ const


Частные случаи неритмичного потока

1. разноритмичные потоки – это потоки с одинаковыми ритмами внутри видов работ (частных потоков) и разными ритмами между различными видами работ (частными потоками)


Tiбр = const, Tjбр = const, Tiбр <> Tjбр;


2. потоки с разными ритмами внутри видов работ и одинаковыми ритмами между различными видами работ на захватках ;


^ Неритмичные потоки

Методы расчета: графический и табличный

Графический метод расчета

Данный метод заключается в построении циклограммы путем последовательной увязки каждого последующего частного с каждым предыдущим. Раcсмотрим этот метод на примере.

Фронт работ разделён на 4 захватки (I, II, III и IV). На них последовательно выполняют работы три бригады, ритмы которых (t1бр, t2бр, t3бр) на каждой захватке заданы в табл.1. Работы выполняются в последовательности, соответствующей увеличению кода захватки. На захватке в любой момент времени может выполняется только одна работа. Циклограмма должна быть построена из условия минимальной продолжительности потока.

Табл. 1

t1бр. t2бр. t3бр

I

4

1

2

II

3

1

2

III

2

2

1

IV

1

4

1




Увязка частных потоков заключается в определении наименьшего из моментов начала работы последующего потока, при котором ни на одной из захваток не будет нарушена технологическая последовательность работ.


Последовательность увязки:

- Наносится первый частный поток.

- Предварительно (пунктиром) наносится последующий частный поток, увязанный по первой захватке.

- На каждой захватке ( кроме первой) определяется величина опережения вступления последующего потока на захватку.

- Определяется максимальное опережение

- Определяется окончательное начало работы последующего потока с учетом максимального опережения и заносится последующий поток. Это равносильно смещению вправо от произвольного (предполагаемого) положения потока на величину максимального опережения.

- Определяются параметры потока .

При минимальной продолжительности работы потока между любыми смежными работами должно быть нулевое сближение (начало работы последующей работы совпадает с окончанием предшествующей) хотя бы на одной захватке.


^ 2 .Табличный метод расчета потоков.


Табличный метод-это числовой вариант графического метода построения циклограммы.

Строки таблицы (табл. 2) соответствуют захваткам. Столбцы (широкие)–работам. В узкие столбцы заносятся опережения. Ритмы работы бригад помещаются по середине соответствующей клетки. В верхнем левом углу клетки заносится дата начала работы бригады на захватке. В правом нижнем углу – окончание работы бригады на захватке.

Начало работы бригады на следующей захватке принимается равным окончанию данной работы на предыдущей захватка (принцип непрерывности работ).

Порядок расчёта:

  1. Принимается дата начала работы первой бригады и рассчитывается начало и окончание работы её на всех захватках;

  2. Начало работы второй (последующей) бригады предварительно привязывается по первой захватке, т. е. начало её работы принимается равным окончанию работы первой (предшествующей) бригады на этой захватки; рассчитываются начала и окончания работы её на всех захватках;

  3. Находятся опережения () времени вступления бригады на захватку на всех захватках;

  4. Начало работы бригады увеличивается на величину максимального опережения и корректируется весь предыдущий (п.2) расчёт;

  5. Привязка третьей бригады ко второй осуществляется точно так же (п. 2…4).

Таблица 2


Δ Δ


I


0

4


4




4 7

1


8 5




8 10

2


12 10


II

4

3


7


2



5 8

1


9 6


1

10 12

2


14 12


III

7

2

9


3



6 9

2


11 8


1

12 14

1


15 13


IV

9

1

10


2



8 11

4

15 12


2


13 15

1


15 14









^

Программа расчёта неритмичного
потока


Программа предназначена для расчёта потока с шестью захватками и семью работами (процессами).

Ввод данных (продолжительности работы бригад на захватке) осуществляется в таблицу ввода данных (рис. 3).


ИСХОДНЫЕ ДАННЫЕ

4




Ритмы работ бригад, дн

5




А

Б

В

Г

Д

Е

Ж

6

I

5

3

5

9

3

1

2

7

II

8

7

2

2

3

2

7

8

III

3

4

8

3

2

6

5

9

IV

8

5

8

6

9

9

7

10

V

6

4

3

2

8

4

3

11

VI

2

6

5

6

2

4

8

12




32

29

31

28

27

26

32







B

C

D

E

F

G

H




















Дата начала работы

= E15

Продолжительность работы потока

= R23-E15



Рис. 3. Таблица ввода данных (ритмов работы бригад)


Данные из рис. 3 переносятся в соответствующие ячейки расчётной таблицы (рис. 4), в которой и производится расчёт параметров потока по вышеизложенному алгоритму.































Бригада 2



Бригада 5



1

=L8

=ЕСЛИ(L9-L28>0;L9-L28;)

=O8

=ЕСЛИ(O8-R28>0;O8-R28;0)

2

=L9+M7

=ЕСЛИ(L11-L29>0;L11-L29;0)

=O8+P7

=ЕСЛИ(O11-R29>0;O11-R29;0)

3

=L8+M7+M10

=ЕСЛИ(L14-L30>0;L14-L30;0)

=R29+P10

=ЕСЛИ(O14-R30>0;O14-R30;0)

4

=L8+M7+M10+M13

=ЕСЛИ(L17-L31>0;L17-L31;0)

=R30+P13

=ЕСЛИ(O17-R31>0;O17-R31;0)

5

=L8+M7+M10+M13+M16

=ЕСЛИ(L20-L32>0;L20-L32;0)

=R31+P16

=ЕСЛИ(O20-R32>0;O20-R32;0)

6

=L32+M19

=ЕСЛИ(L23-L33>0;L23-L33;0)

=R32+P19

=ЕСЛИ(O23-R33>0;O23-R33;0)







=МАКС(M28:M33)




=МАКС(S28:S33)







Бригада 3



Бригада 6






=N28

=ЕСЛИ(M8-N28>0;M8-N28;0)

=P8

=ЕСЛИ(P8-L39>0;P8-L39;0)




=M8+N7

=ЕСЛИ(M11-N29>0;M11-N29;0)

=P8+Q7

=ЕСЛИ(P11-L40>0;P11-L40;0)




=N29+N10

=ЕСЛИ(M14-N30>0;M14-N30;0)

=Q7+P8+Q10

=ЕСЛИ(P14-L41>0;P14-L41;0)




=N30+N13

=ЕСЛИ(M17-N31>0;M17-N31;0)

=L41+Q13

=ЕСЛИ(P17-L42>0;P17-L42;0)




=N31+N16

=ЕСЛИ(M20-N32>0;M20-N32;0)

=L42+Q16

=ЕСЛИ(P20-L43>0;P20-L43;0)




=N32+N19

=ЕСЛИ(M23-N33>0;M23-N33;0)

=L43+Q19

=ЕСЛИ(P23-L44>0;P23-L44;0)







=МАКС(O28:O31)




=МАКС(M39:M44)







Бригада 4



Бригада 7






=N8

=ЕСЛИ(N8-P28>0;N8-P28;0)

=Q8

=ЕСЛИ(Q8-N39>0;Q8-N39;0)




=N8+O7

=ЕСЛИ(N11-P29>0;N11-P29;0)

=Q8+R7

=ЕСЛИ(Q11-N40>0;Q11-N40;0)




=P29+O10

=ЕСЛИ(N14-P30>0;N14-P30;0)

=Q8+R7+R10

=ЕСЛИ(Q14-N41>0;Q14-N41;0)




=P30+O13

=ЕСЛИ(N17-P31>0;N17-P31;0)

=N41+R13

=ЕСЛИ(Q17-N42>0;Q17-N42;0)




=P31+O16

=ЕСЛИ(N20-P32>0;N20-P32;0)

=N42+R16

=ЕСЛИ(Q20-N43>0;Q20-N43;0)




=P32+O19

=ЕСЛИ(N20-P32>0;N20-P32;0)

=N43+R19

=ЕСЛИ(Q23-N44>0;Q23-N44;0)







=МАКС(Q28:Q33)




=МАКС(O39:O44)
























































Расчет потока

Расчетная таблица

5




А

Б

В

Г

Д

Е

Ж

6




=E15

=L9+M34

=M8+O34

=N8+Q34

=O8+S34

=P8+M45

=Q8+O45

7

1

=B6

=M7

=D6

=E6

=F6

=G6

=H6

8




=L6+L7

=M6+M7

=N6+N7

=O6+O7

=P6+P7

=Q6+Q7

=R6+R7

9




=L8

=M8

=N8

=O8

=P8

=Q8

=R8

10

2

=B7

=C7

=D7

=E7

=F7

=G7

=H7

11




=L10+L9

=M9+M10

=N9+N10

=O9+O10

=P9+P10

=Q9+Q10

=R9+R10

12




=L11

=M11

=N11

=O11

=P11

=Q11

=R11

13

3

=B8

=C8

=D8

=E8

=F8

=G8

=H8

14




=L12+L13

=M12+M13

=N12+N13

=O12+O13

=P12+P13

=Q12+Q13

=R12+R13

15




=L14

=M14

=N14

=O14

=P14

=Q14

=R14

16

4

=B9

=C9

=D9

=E9

=F9

=G9

=H9

17




=L15+L16

=M15+M16

=N15+N16

=O15+O16

=P15+P16

=Q15+Q16

=R15+R16

18




=L17

=M17

=N17

=O17

=P17

=Q17

=R17

19

5

=B10

=C10

=D10

=E10

=F10

=G10

=H10

20




=L18+L19

=M18+M19

=N18+N19

=O18+O19

=P18+P19

=Q18+Q19

=R18+R19

21




=L20

=M20

=N20

=O20

=P20

=Q20

=R20

22

6

=B11

=C11

=D11

=E11

=F11

=G11

=H11

23




=L21+L22

=M21+M22

=N21+N22

=O22+O21

=P21+P22

=Q21+Q22

=R21+R22

24

K

L

M

N

O

P

Q

R



Рис. 4 Расчётная таблица (программа)


^ Построение графика (циклограммы) потока


Циклограмма потока строится как точечный график на основании промежуточной таблицы (рис. 5), которая содержит координаты точек пересечения линий работы бригад с границами захваток. В первой графе содержаться координаты Y, а каждая последующая графа таблицы содержит соответствующие временные координаты X.




T

U

V

W

X

Y

Z

AA


































16

1

L8

M8

N8

O8

P8

Q8

R8




17

2

L11

M11

N11

O11

P11

Q11

R11




18

3

L14

M14

N14

P14

P14

Q14

R14




19

4

L17

M17

N17

P17

P17

Q17

R17




20

5

L20

M20

N20

P20

P20

Q20

R20




21

6

L23

M23

N23

P23

P23

Q23

R23


































Рис. 5. Таблица координат точек графика


Циклограмма строится с помощью мастера диаграмм. На рис.6 представлено первое окно мастера, в котором производится выбор типа диаграмм.



Рис. 6. Первое окно мастера диаграмм: выбор типа диаграммы.


Во втором окне мастера диаграмм (рис. 7) необходимо ввести координаты точек каждого графика (ряда) и название ряда.




Рис. 7. Второе окно мастера диаграмм: ввод координат и названий рядов.

На рис. 8 представлена циклограмма потока.


На рис. 8 представлена циклограмма потока. Она пустая, т.е. не содержит графиков работы бригад, которые будут появляться по мере ввода данных в табл. (рис. 3).



Рис. 8. Циклограмма потока (форма)


^ Сценарий работы с программой


Работа программы начинается с автоматического запуска макроса Auto_open, который подготавливает окно программы, удаляя с него все ненужные элементы и ненужную для работы программы информацию, и выводит на экран титульную страницу (рис. 9).




Скачать файл (2634.5 kb.)

Поиск по сайту:  

© gendocs.ru
При копировании укажите ссылку.
обратиться к администрации
Рейтинг@Mail.ru