Logo GenDocs.ru

Поиск по сайту:  

Загрузка...

АмГУ. Методички к лабораторным работам по имитационному моделированию - файл ЛАБОРАТОРНАЯ РАБОТА 2 - МК.docx


Загрузка...
АмГУ. Методички к лабораторным работам по имитационному моделированию
скачать (552 kb.)

Доступные файлы (6):

ЛАБОРАТОРНАЯ РАБОТА 1 - ЛОЗ.doc123kb.12.02.2008 00:51скачать
ЛАБОРАТОРНАЯ РАБОТА 2 - МК.docx111kb.04.02.2008 22:00скачать
ЛАБОРАТОРНАЯ РАБОТА 3 - УП.docx125kb.02.02.2008 20:33скачать
ЛАБОРАТОРНАЯ РАБОТА 4 - СМО.doc133kb.25.03.2008 22:56скачать
ЛАБОРАТОРНАЯ РАБОТА 5 - ОР.doc484kb.20.03.2008 17:16скачать
ЛАБОРАТОРНАЯ РАБОТА 6 - ОР.doc592kb.15.03.2008 12:38скачать

ЛАБОРАТОРНАЯ РАБОТА 2 - МК.docx

Реклама MarketGid:
Загрузка...
ЛАБОРАТОРНАЯ РАБОТА №2

Имитационное моделирование для

решения инженерно-вычислительых задач (методом Монте-Карло)


  1. Подготовительная часть.

Для выполнения лабораторной работы необходимо повторить следующие вопросы:

  1. Вычисление площади фигуры, ограниченной кривыми.

  2. Понятие и расчет доверительного интервала.




  1. Теоретическая часть.

Пример 1. Пусть требуется определить площадь круга известного диаметра с помощью выборок из значений случайной величины. Впишем круг в квадрат; таким образом, стороны квадрата будут равны диаметру круга.

Пусть круг имеет радиус г=5 см и его центр в точке (0,0).
Уравнение окружности будет иметь вид

x2+y2=25

Описанный квадрат определяется его вершинами (—5, 5), (5, 5), (5, -5) и (-5, -5), которые получаются непосредственно из геометрических свойств фигуры. Любая точка (х, у) внутри квадрата или на его границе должна удовлетворять неравенствам —5≤х≤5 и —5≤у≤5

Применение выборок при использовании метода Монте-Карло основано на предположении, что все точки в квадрате —5≤х≤5 и —5≤у≤5 могут появляться с одинаковой вероятностью, т. е. х и у распределены равномерно с плотностями вероятности
1/10, —5≤х≤5

f(x)=

  1. в противном случае


1/10, —5≤y≤5

f(y)=

  1. в противном случае



Определим теперь точку (х, у) в соответствии с распределениями f(x) и f(у). Продолжая этот процесс, подсчитаем число точек, попавших внутрь круга или на окружность. Предположим, что вы

борка состоит из п наблюдений и т из п точек попали внутрь круга или на окружность. Тогда
оценка площади круга = m/n(площадь квадрата)=(m/n)*(10*10)
Подобный способ оценивания площади круга можно обосновать тем, что в процессе получения выборки любая точка (х, у) может с одинаковой вероятностью попасть в любое место 

квадрата. Поэтому отношение m/n представляет оценку площади круга относительно площади квадрата.


  1. Использование Excel для постановки эксперимента.

Для получения выборки случайных чисел с заданным распределением можно воспользоваться функцией «Генерация случайных чисел» из меню «Анализ данных».





A

B

C

1

-2,69432660908841

-1,50318918424024

=ЕСЛИ(A1*A1+B1*B1<=25;1;0)

2

0,626392406994842

-4,30265205847346

=ЕСЛИ(A2*A2+B2*B2<=25;1;0)

3

-4,60478530228584

-1,3075655384991

=ЕСЛИ(A3*A3+B3*B3<=25;1;0)

4

-4,74211859492782

0,307168797875912

=ЕСЛИ(A4*A4+B4*B4<=25;1;0)

5

3,57356486709189

-4,41953794976653

=ЕСЛИ(A5*A5+B5*B5<=25;1;0)




































148

-4,65086825159459

2,68517105624561

=ЕСЛИ(A148*A148+B148*B148<=25;1;0)

149

-3,85921811578722

-4,19644764549699

=ЕСЛИ(A149*A149+B149*B149<=25;1;0)

150

2,46147038178655

3,33826715903195

=ЕСЛИ(A150*A150+B150*B150<=25;1;0)

151

 

число попаданий

=СУММ(C1:C150)

152

 

число наблюдений

=СЧЁТ(C1:C150)

153

 

площадь круга

=(C151/C152)*100



  1. Использование MathCad для постановки эксперимента.

Для решения аналогичной задачи в системе MathCad можно воспользоваться программным модулем с использованием функции rnd(х), возвращающей случайное число в диапазоне от 0 до х. В данном модуле n – число наблюдений.



  1. 

  2. Использование Matlab для постановки эксперимента.


Для решения данной задачи в системе Matlab можно воспользоваться следующей М-функцией:
function[s]=sum(n)

m=0;

for i=1:n

x=Random('unif',-5,5);

y=Random('unif',-5,5);

if x*x+y*y<=25

m=m+1;

end;

end;

s=(m/n)*100;
Здесь параметр ‘unif’ функции Random позволяет получить равномерно распределенное случайное число.


  1. Обработка результатов

Для изучения влияния статистической ошибки при моделирова

нии задача решалась для различных значений п, равных 150, 200, 500, 1000, 2000, 5000 и 10 000. Кроме того, при каждом п было про

ведено 10 прогонов, в каждом из которых использовались различные последовательности случайных чисел из интервала [-5, 5].


^ Номер
прогона


Оценки площади круга при данном числе испытаний n

150

200

500

1000

2000

5000

1

76

80,5

76

78,6

79,55

78,32

2

82

79,5

79,6

78,8

78,85

79,26

3

86

81,5

76,6

77,6

79,1

77,22

4

75

82

78,8

80

79,55

79,34

5

77

72

76,2

79,8

79,4

79,22

6

81

77,5

76,6

77,6

77,4

77,44

7

75

81,5

80,4

78,5

78,1

79,28

8

74

76,5

81,8

79,7

77,2

78,82

9

71

80,5

76,6

76,4

77,76

78,74

10

84

72

81,2

78

78,4

77,74

Среднее

78,1

78,35

78,38

78,5

78,531

78,538

Дисперсия

23,65556

14,28056

5,035111

1,306667

0,789499

0,658618

























^ Расчетное значение

78,54








В таблице приведены результаты эксперимента, исходя из которых можно сделать следующие заключения.

1. С ростом числа генерируемых точек (т. е. продолжительности прогона модели) оценки площади круга приближаются к точному значению (78,54 см2). На рис. 2 показаны оценки площади прогонов 1 и 2 в зависимости от продолжительности прогона п. Мы видим, что сначала оценки колеблются около точного значения, а затем стабилизируются. Это условие обычно достигается после по

вторения эксперимента достаточное количество раз. Наблюдаемое явление типично для результатов любой имитационной модели. Обычно в большинстве имитационных моделей нас интересуют результаты, полученные в стационарных условиях.


Рис. 2
2. Влияние переходных условий умень

шается, если усреднить результаты 10 серий. Это иллюстрирует рис. 3, на котором показана зависимость среднего от п. Кроме того, на рисунках видно, что для каждого п при достижении стацио

нарных условий дисперсия убывает. При возрастании п от 150 до 200 дисперсия резко уменьшается с 23,66 до 14,25. За исключением этого интервала, столь резкого уменьшения дисперсии нигде больше не наблюдается. Последнее замечание указывает на то, что сущест

вует предел, за которым увеличение продолжительности прогона модели уже не дает существенного повышения точности результа

та, измеряемой дисперсией. Это замечание представляется чрезвы

чайно важным, поскольку затраты на эксплуатацию имитационной модели прямо пропорциональны продолжительности прогонов. Поэтому желательно найти компромисс между большой точностью (т. е. малой дисперсией) и небольшими затратами на процедуру получения результатов.




Рис.3.
3. Ввиду того что оценки площади имеют разброс, важно, чтобы результаты эксперимента, связанного с моделированием, были вы

ражены в виде доверительных интервалов, показывающих величину отклонения от точного значений. В рассматриваемом примере, если А представляет собой точное значение площади, а А и s2 — среднее и дисперсию N наблюдений, то 100 (1—α)%-ный доверительный ин

тервал для А задается как
A-sN t∝2,N-1≤A≤ A+sN t∝2,N-1
^ 3. Практическая часть.

Проверить решение Примера 1 с использованием разных пакетов. Решение задания 2 также привести в разных пакетах (Excel, MathCad, Matlab). Решение задач 1 и 3 можно осуществить в любом пакете. Результаты, полученные с помощью моделирования в задании 2 сравнить с расчетным результатом.
Для отчета необходимо:

  1. Для каждого задания привести математическую модель эксперимента

  2. Привести тексты модулей решения всех заданий.

  3. Определить оптимальное количество экспериментов с помощью оценки дисперсии.

  4. Произвести обработку результатов моделирования и представить ответ в виде доверительных интервалов для искомой величины.


Задание 1.

  1. Решить задачу «случайных блужданий» в ее классической трактовке.

  2. Дополнить модель, учитывая, что человек делает шаги вперед в 2 раза чаще, чем шаги назад.

  3. Дополнить модель задачи, учитывая, что человек делает шаг не только по диагонали, но и строго вперед (назад), вправо (влево).

Задание 2 (по вариантам)

  1. Найти площадь фигуры, ограниченной линиями:

y=sin(x)+2

y=9-x2

y=0

  1. 

  2. Найти площадь фигуры, ограниченной линиями:

y=e0,4x

y=25-x2

y=0

  1. Найти площадь фигуры, ограниченной линиями:

y=0,2x2

y=10,2x

x=0

y=4

  1. Найти площадь фигуры, ограниченной линиями:

y=tg(x)

y=1x

y=0

x=3
Задание 3.

Из отверстия А трубки длиной L вылетают частицы под углом α (α – случайная величина, распределенная равномерно). Частицы могут сколь угодно много раз отталкиваться от стенок трубки. Составить математическую модель и провести эксперимент для определения доли частиц, попадающих в выделенную область. Для упрощения модели пренебречь диаметром отверстия А, диаметром частиц, затуханием колебаний частиц.


Скачать файл (552 kb.)

Поиск по сайту:  

© gendocs.ru
При копировании укажите ссылку.
обратиться к администрации