Logo GenDocs.ru

Поиск по сайту:  

Загрузка...

АмГУ. Методички к лабораторным работам по имитационному моделированию - файл ЛАБОРАТОРНАЯ РАБОТА 3 - УП.docx


Загрузка...
АмГУ. Методички к лабораторным работам по имитационному моделированию
скачать (552 kb.)

Доступные файлы (6):

ЛАБОРАТОРНАЯ РАБОТА 1 - ЛОЗ.doc123kb.12.02.2008 00:51скачать
ЛАБОРАТОРНАЯ РАБОТА 2 - МК.docx111kb.04.02.2008 22:00скачать
ЛАБОРАТОРНАЯ РАБОТА 3 - УП.docx125kb.02.02.2008 20:33скачать
ЛАБОРАТОРНАЯ РАБОТА 4 - СМО.doc133kb.25.03.2008 22:56скачать
ЛАБОРАТОРНАЯ РАБОТА 5 - ОР.doc484kb.20.03.2008 17:16скачать
ЛАБОРАТОРНАЯ РАБОТА 6 - ОР.doc592kb.15.03.2008 12:38скачать

ЛАБОРАТОРНАЯ РАБОТА 3 - УП.docx

Реклама MarketGid:
Загрузка...
ЛАБОРАТОРНАЯ РАБОТА №3

Имитационное моделирование для

решения задач организационного управления


  1. Подготовительная часть.

Для выполнения лабораторной работы необходимо повторить следующие вопросы:

  1. Распределение случайной величины




  1. Теоретическая часть.

Пример 1. Система включает в себя 5 приборов:


Вероятность выхода из строя каждого прибора указана на рисунке. С помощью имитационной модели найти вероятность выхода из строя всей системы.

Очевидно, что вероятность выхода из строя всей системы произойдет в случае, если выйдут из строя приборы 1 или 4 или 5 или одновременно 1 и 2.

При моделировании для каждого прибора необходимо предусмотреть случайные числа, равномерно распределенные в интервале от 0 до 99. При этом 13% этих чисел для 1-го прибора будут отображать 13%-ю вероятность выхода из строя 1-го прибора, 30% чисел – 30%-ю вероятность выхода из строя 2-го прибора и т.д. Таким образом, имея случайные числа в диапазоне от 1 до 100, экспериментальную таблицу можно представить следующим образом:

Таблица 1.

Выход прибора из строя

1

2

3

4

5

Случайное число

0-13

0-30

0-30

0-11

0-15


Модель в среде табличного процессора Excel может выглядеть следующим образом:
Таблица 2.

^ Случайные числа для прибора

Выход из строя прибора (1-вышел из строя)

Выход из
строя системы


1

2

3

4

5

1

2 или 3

4

5

65

21

13

54

86

0

1

0

0

1

11

33

23

22

26

1

0

0

0

1

72

27

36

88

14

0

0

0

1

1

83

25

71

81

68

0

0

0

0

0

27

74

56

44

69

0

0

0

0

0


Макет 1-3 строк данного листа Excel приведен ниже:

^ Случайные числа для прибора

1

2

3

4

5

=СЛУЧМЕЖДУ(0;99)

=СЛУЧМЕЖДУ(0;99)

=СЛУЧМЕЖДУ(0;99)

=СЛУЧМЕЖДУ(0;99)

=СЛУЧМЕЖДУ(0;99)




^ Выход из строя прибора (1-вышел из строя)

Выход из
строя системы


1

2 или 3

4

5

=ЕСЛИ(A3>13;0;1)

=ЕСЛИ(И((B3<30);(C3<30));1;0)

=ЕСЛИ(D3>11;0;1)

=ЕСЛИ(E3>15;0;1)

=СУММ(F3:I3)



Выполнив определенное число экспериментов, можно с заданной точностью определить вероятность выхода из строя всей системы.

^ Пример 2. Управление запасами. Спрос на некую модель телевизора показан в таблице:

Таблица 3.

Ежедневный спрос

Кол-во проданных телевизоров

0

1

2

3

4

Процентная частота

10

22

37

28

3


Известно, что

1) Исходный уровень запасов составляет 12 телевизоров.

2) Уровень запасов проверяется в начале каждого дня. Когда он становит

ся менее 10, размещается заказ на новую партию из 8 телеви

зоров.

3) Заказ исполняется за 2 дня.

Требуется определить:

а) средний уровень запасов;

б) количество заказов, которое необходимо разместить в течение 15 дней.
Как и в предыдущим примере, для построения модели можно взять двузначные случайные числа. Первые 10% случайных чисел (00—09) показывают нулевой спрос, следую

щие 22% — спрос на 1 телевизор и т. д. В таблице ниже показаны случайные числа, которые будут использоваться при моделировании спроса на телеви

зоры:
Таблица 4.

Ежедневный спрос


Кол-во телевизоров:

0

1

2

3

4

Случайные числа:

00 - 09

10-31

32 - 68

69 - 96

97-99


С помощью таблицы случайных чисел можно смоделировать спрос на те

левизоры в течение определенного периода. В таблице показана модель спроса в течение 15 дней:
Таблица 5.

день

исходный
уровень запасов


спрос

размещенные
заказы


^ Полученные
заказы


уровень запасов
при закрытии


случ. число

величина

1

12

20

1

0

0

11

2

11

14

1

0

0

10

3

10

19

1

0

0

9

4

9

31

1

8

0

8

5

8

2

0

0

0

8

6

8

89

3

0

8

13

7

13

63

2

0

0

11

8

11

63

2

0

0

9

9

9

3

0

8

0

9

10

9

16

1

0

0

8

11

8

12

1

0

8

15

12

15

67

2

0

0

13

13

13

0

0

0

0

13

14

13

91

3

0

0

10

15

10

37

2

0

0

8

В этой таблице значения в столбцах получены следующим образом:
1)^ Спрос. Эти значения смоделированы с помощью случайных чисел и в соответствии с таблицей 4.

2) Исходный уровень запасов. В день 1 исходный уровень запасов известен и равен 12. В последующие дни исходный уровень запасов равен уровню запасов по закрытии предыдущего дня.

3)^ Размещение заказов. Заказ на 8 телевизоров размещается в тот день, когда уровень запасов становится равен 10 или менее телевизорам. До получения текущего заказа другие заказы не размещаются (т.е. как минимум в 2 предыдущих дня не было сделано заказов).

4)^ Получение заказов. Доставка 8-ми телевизоров займет два дня после размещения заказа.

5) Уровень запасов при закрытии. Уровень запасов в конце каждого дня рассчитывается следующим образом:

Уровень запасов при закрытии = Исходный уровень запасов - Спрос + Полученные заказы
Из полученной таблицы можно получить значения среднего уровня запасов (для данного случая – 10,6 шт.) и частоту размещения заказов (для данного случая – 2).

Решение данной задачи в среде Matlab приведено ниже:


начало

%1 строка

A(1,1)=1;

A(1,2)=12;

x=random('unif',0,99)

if x<10

A(1,3)=0

elseif x<32

A(1,3)=1

elseif x<69

A(1,3)=2

elseif x<98

A(1,3)=3

else

A(1,3)=4

end;

A(1,4)=0;

A(1,5)=0;

A(1,6)=A(1,2)-A(1,3);

%2 строка

A(2,1)=2;

A(2,2)=A(1,6);

x=random('unif',0,99)

if x<10

A(2,3)=0

elseif x<32

A(2,3)=1

elseif x<69

A(2,3)=2

elseif x<98

A(2,3)=3

else

A(2,3)=4

end;


окончание

if A(2,2)<10

A(2,4)=8;

end

A(2,5)=0;

A(2,6)=A(2,2)-A(2,3)+A(2,5);

% остальные строки

for i=3:15

A(i,1)=i

A(i,2)=A(i-1,6)

x=random('unif',0,99)

if x<10

A(i,3)=0

elseif x<32

A(i,3)=1

elseif x<69

A(i,3)=2

elseif x<98

A(i,3)=3

else

A(i,3)=4

end;

if (A(i,2)<10)&(A(i-1,4)==0)&(A(i-2,4)==0)

A(i,4)=8;

end

if A(i-2,4)==8

A(i,5)=8;

else

A(i,5)=0;

end

A(i,6)=A(i,2)-A(i,3)+A(i,5)

End





Здесь столбцы матрицы A имеют следующие значения:

1 – день

2 – исходный уровень запасов

3 – спрос

4 – размещенные заказы

5 – полученные заказы

6 – уровень запасов при закрытии

Пример 2.1. В предыдущей модели не учтено возникновение дефицита в том случае, когда уровень запасов меньше спроса. Рассмотрим ситуацию, когда размещается заказ на 4 телевизора при достижении уровня запасов отметки 3 и менее телевизоров.

Известно следующее:

1) Продажная цена телевизора составляет 100 у.е.

2) Затраты вследствие дефицита составляют 150 у.е. на непродан

ную единицу.

3) Затраты на хранение запасов составляют 5 у.е. в день на 1 телевизор (исходя из исходного уровня запасов).

Экспериментальная таблица для переработанной модели будет выглядеть следующим образом:


день

исходный
уровень запасов

спрос

размещенные
заказы

Полученные
заказы

Дефицит

Продано

Выручка

Затраты на хранение

Затраты вследствие дефицита

уровень
при закрытии

случ.
число

величина

1

12

93

3

0

0

0

3

300

60

0

9

2

9

65

2

0

0

0

2

200

45

0

7

3

7

94

3

0

0

0

3

300

35

0

4

4

4

20

1

0

0

0

1

100

20

0

3

5

3

8

0

4

0

0

0

0

15

0

3

6

3

84

3

0

0

0

3

300

15

0

0

7

0

51

2

0

4

0

2

200

0

0

2

8

2

66

2

4

0

0

2

200

10

0

0

9

0

62

2

0

0

-2

0

0

0

300

0

10

0

72

3

0

4

0

3

300

0

0

1

11

1

24

1

4

0

0

1

100

5

0

0

12

0

42

2

0

0

-2

0

0

0

300

0

13

0

46

2

0

4

0

2

200

0

0

2

14

2

15

1

4

0

0

1

100

10

0

1

15

1

68

3

0

0

-2

1

100

5

300

0



Макет данного листа в среде Excel выглядит следующим образом:


день

исходный
уровень запасов


спрос


случ.
число


величина

1

12

=СЛУЧМЕЖДУ(0;99)

=ЕСЛИ(C3<10;0;ЕСЛИ(C3<32;1;ЕСЛИ(C3<68;2;ЕСЛИ(C3<97;3;4))))

2

=L3

=СЛУЧМЕЖДУ(0;99)

=ЕСЛИ(C4<10;0;ЕСЛИ(C4<32;1;ЕСЛИ(C4<68;2;ЕСЛИ(C4<97;3;4))))

3

=L4

=СЛУЧМЕЖДУ(0;99)

=ЕСЛИ(C5<10;0;ЕСЛИ(C5<32;1;ЕСЛИ(C5<68;2;ЕСЛИ(C5<97;3;4))))



размещенные
заказы


Полученные
заказы


Дефицит

Продано

=ЕСЛИ(B3<10;4;0)

0

=ЕСЛИ((B3+F3)<D3;B3-D3;0)

=D3+G3

=ЕСЛИ(B4<4;4;0)

0

=ЕСЛИ((B4+F4)<D4;B4-D4;0)

=D4+G4

=ЕСЛИ(И(B5<4;E4=0;E3=0);4;0)

=ЕСЛИ(E3=4;4;0)

=ЕСЛИ((B5+F5)<D5;B5-D5;0)

=D5+G5

^ Выручка

Затраты на хранение

Затраты вследствие дефицита

уровень
при закрытии


=H3*100

=5*B3

=G3*(-1)*150

=ЕСЛИ(B3-D3+F3<0;0;B3-D3+F3)

=H4*100

=5*B4

=G4*(-1)*150

=ЕСЛИ(B4-D4+F4<0;0;B4-D4+F4)

=H5*100

=5*B5

=G5*(-1)*150

=ЕСЛИ(B5-D5+F5<0;0;B5-D5+F5)


^ Пример 3. Анализ вариантов обслуживания автобусов.

Каждый рейсовый автобус должен по плану сделать ровно N рейсов в день. Каждый день свой первый рейс автобус начинает в хорошем, т.е. полностью исправном состоянии. Если автобус начинает определенный рейс в хорошем состоянии, то он имеет ненулевую вероятность того, что закончит его в некотором ухудшенном состоянии.

Ухудшенное состояние автобуса характеризуется тем, что автобус может продолжать свой путь, т.е. возникла некая небольшая неисправность. Ремонт такой неисправности занял бы время одного рейса, причем производится он по окончании текущего рейса.

Если автобус продолжает работу в ухудшенном состоянии, то существует некоторая ненулевая вероятность, что он может перейти в полностью нерабочее состояние. В этом случае приходится отменять все оставшиеся на текущий день рейсы, т.к. автобус будет находиться в ремонте до конца дня. Каждый новый день автобус начинает в исправном состоянии независимо от того, в каком состоянии закончил предыдущий день.

Администрация парка выбирает между двух правил (стратегий):

Правило 1 – производить ремонт небольших неисправностей сразу же, как автобус переходит в ухудшенное состояние

Правило 2 – эксплуатировать автобус до его полной поломки, не устраняя небольших неисправностей.

Определить правило, при котором обеспечивается максимум среднего числа рейсов в день.
Все возможные состояния автобуса (и переходы) можно изобразить в виде графа:




Очевидно, что при следовании Правилу 1, автобус может находиться только в состояниях 1 или 0, причем переход из состояния 1 в состояние 0 возможен с вероятностью РА. Из состояния 0 автобус всегда переходит в состояние 1 с потерей 1 рейса.

В качестве примера приведено решение задачи для Правила 1 в среде MathCad. Здесь принята вероятность PA перехода из состояния 1 (автобус полностью исправен) в состояние 0 (автобус неисправен) равной 30%. Число строк матрицы А соответствуют числу экспериментальных дней, число столбцов – числу планируемых рейсов в день плюс суммарный столбец (Ak,N-1) – количество произведенных рейсов. Переменная SR определяет среднее количество произведенных рейсов в день в течении заданных экспериментальных дней.

  1. Практическая часть

Перед тем, как приступить к выполнению заданий практической части, рекомендуется проверить решения приведенных в теоретической части примеров.

Задание 1 рекомендуется выполнить во всех 3 предложенных средах (MathCad, Matlab, Excel).

Задания 2 и 3 можно выполнять в любой из предложенных сред.

Отчет по лабораторной работе должен содержать для каждого задания:

  1. 

  2. Математическую модель эксперимента

  3. Тексты модулей (макет листа для Excel) решения всех задач

  4. Обработанные результаты моделирования (с определением оптимального числа прогонов каждой модели).


Задание 1. (по вариантам)
Вероятность отказа каждого из приборов в цепи показана на рисунке. Определить вероятность отказа всей цепи:

Вариант 1




Вариант 2




Вариант 3




Задание 2.

Магазин электротоваров реализует стиральные машины. Дневной спрос на стиральные машины распределен следующим образом:


Дневной спрос:

1

2

3

4 5

5

6

Процент

10

30

30

20

5

5


Запасы обычно пополняются при достижении уровня в 6 единиц и менее, при этом размер заказа составляет 8 стиральных машин, а цикл заказа — 3 дня.

При условии, что первоначальный запас составляет 10 стиральных машин, определите с помощью метода моделирования спрос на этот товар в течение 20 дней. Какова вероятность возникновения дефицита при проведении такой по

литики размещения заказов?
Задание 3.

Дополните модель из задания 2 следующей информацией:

а) Стиральные машины продаются в розницу по цене 9000 руб. за штуку.

б) Стоимость приобретения у производителя одной машины составляет 5500 руб..

в) Затраты на оформление заказа составляют 1400 руб. на один заказ в виде административных издержек и расходов по доставке.

г) Неудовлетворенная потребность обходится магазину в 5000 руб.

Определите наилучшую стратегию размещения заказов из следующих:

  1. заказывать по 10 машин в одной партии при точке заказа в 8 или менее

  2. заказывать по 20 машин при точке заказа от 10 и ниже


Задание 4. Разработайте модель для Правила 2 из примера 3 и определите наилучшее правило обслуживания автобусов.


Скачать файл (552 kb.)

Поиск по сайту:  

© gendocs.ru
При копировании укажите ссылку.
обратиться к администрации